通达信锤子形态公式

量化交易 1894 Views

操作要点:1.锤子的形态,其反转点以第二天是否过高为判断依据,若破锤子实体低点,则可能需要止损操作。2.其次第二天的量能不能出现倍量,最好是能出现温和放量的小阳线,则后期的涨幅可以相对乐观。3.从随机翻查的十几个个股来看,出现以上确认买点信号(过锤子高点),盈利3~5%成功概率极高,只是锤子信号出现的概率不高,需长时间等待。}

第三版本,功能说明:在第二版本的基础上添加了针对股本的判断,上一版本中,锤子形态在大盘股中触发条件的概率不高,经审查发现,是因为大盘股其下跌周期较长,下跌幅度相对较小,所以在本次公式内设定了对流通股本的判断,即盘子越大的股票,其下跌幅度的要求越小,下跌周期也相应缩短。

1.去除低量判断。2.添加允许少量上引线,下引线长度改短,为K线总长度的50%。3.实测只要第二天高过锤子的最高价时,买入获利4%以上概率,高达95%,获利10各点以上的概率也高达74%。特别是周线级别的锤子,获利30%的也有。只是周线出现信号的概率更低。4.以上数据经过通达信专家系统的初步测试。测试时止损位设置为-2%;}

指标源码T1:=IF(FINANCE(40)>=100000000000,40, {流通市值大于1000亿的,要求下跌40天}IF(FINANCE(40)>=50000000000,45, {流通市值大于500亿的,要求下跌45天} IF(FINANCE(40)>=30000000000,50, {流通市值大于300亿的,要求下跌50天} IF(FINANCE(40)>=20000000000,50, {流通市值大于200亿的,要求下跌50天} IF(FINANCE(40)>=10000000000,55, {流通市值大于100亿的,要求下跌55天} IF(FINANCE(40)>=5000000000,60, {流通市值大于50亿的,要求下跌60天}65 {流通市值小于50亿的,要求下跌65天}))))));N1:=IF(FINANCE(40)>=100000000000,15, {流通市值大于1000亿的,下跌幅度N1赋值15}IF(FINANCE(40)>=50000000000,18, {流通市值大于500亿的,下跌幅度N1赋值18} IF(FINANCE(40)>=30000000000,18, {流通市值大于300亿的,下跌幅度N1赋值18} IF(FINANCE(40)>=20000000000,25, {流通市值大于200亿的,下跌幅度N1赋值25} IF(FINANCE(40)>=10000000000,25, {流通市值大于100亿的,下跌幅度N1赋值25} IF(FINANCE(40)>=5000000000,25, {流通市值大于50亿的,下跌幅度N1赋值25}30               {流通市值小于50亿的,下跌幅度N1赋值30}))))));DOWN_20P:=100*(HHV(C,T1)/REF(C,1)-1) > N1;    {寻找60天内下跌超过N %的个股}锤子形态:=(MIN(REF(CLOSE,1),REF(OPEN,1))-REF(LOW,1))/(REF(HIGH,1)-REF(LOW,1))>0.5 {下影线超过2/3}AND (REF(HIGH,1)-MAX(REF(CLOSE,1),REF(OPEN,1))) < ABS(REF(O,1)-REF(C,1))/4 {有少量上影线}AND LLV(LOW,T1)=REF(LOW,1);{锤子当天收60天以内的最低价}OUT:锤子形态AND DOWN_20PAND C>REF(H,1); {今天K线过昨天高点,确认锤子形态}

如未说明则本站原创,转载请注明出处:NULL » 通达信锤子形态公式