今日指标:史上最牛黄金分割分时主图通达信+大智慧版源码奉献

量化交易 626 Views

简介

今天是小年夜,几个朋友小酌之后有点高兴,兴奋之于就把源码奉献出来供大家分享提炼优化。

说明:1、史上最牛分时主图本论坛已经有坛友提供使用,但是加密的,不是源码,坛友不能提高优化,网址连接我就省略了。 2、本人提供的是大智慧版源码,考虑大多数坛友使用的是通达信行情软件,20%的坛友使用的是大智慧及其他行情软件,我在大智慧源码的基础上做成了通达信版本的源码,同时添加了李驳老师的黄金分割源码,黄金分割一般用在日K线主图上,李驳老师用在分时主图上是一个创新,我觉得很好,因此我就添加了李驳老师的源码。在此,感谢李驳老师的分享。

{通达信分时主图用}DRAWTEXT_FIX(1,0.09,0,0,'所属行业:')COLOR0080FF; DRAWTEXT_FIX(1,0.18,0,0,HYBLOCK)COLOR0080FF; DRAWTEXT_FIX(1,0.27,0,0,'所属地区:')COLOR00FFFF; DRAWTEXT_FIX(1,0.36,0,0,DYBLOCK)COLOR00FFFF; MA30:=EMA(CLOSE,30); 强弱界定:EMA(CLOSE,900); STICKLINE((MA30>强弱界定),MA30,强弱界定,1,0),COLOR0000FF; STICKLINE((MA30<强弱界定),MA30,强弱界定,1,0),COLOR00FF00; DRAWICON(CROSS(MA30,强弱界定),H,1); AAA:DYNAINFO(5),COLORDDAADD,LINETHICK1;{最高} BBB:DYNAINFO(6),COLOR888800,LINETHICK1;{最低} CCC:=AAA-BBB; 中G:(AAA+BBB)/2,COLOR999999,LINETHICK1;{中} 上顶:BBB+CCC*7/8,COLOR008800,DOTLINE; 阻力:BBB+CCC*2/3,COLOR777700,DOTLINE; 支撑:BBB+CCC/3,COLOR777700,DOTLINE; 下底:BBB+CCC*1/8,COLOR447777,DOTLINE; JJA:=C,COLOR999999,LINETHICK2; 支撑2:BBB+CCC*0.5/8,DOTLINE,COLOR00DD00; DRAWNUMBER(CURRBARSCOUNT=12,AAA*0.9995,AAA),COLORFFAAFF; DRAWNUMBER(CURRBARSCOUNT=12,BBB,BBB),COLORDDDD00; DRAWNUMBER(CURRBARSCOUNT=12,中G,中G),COLORDDDDDD; DRAWNUMBER(CURRBARSCOUNT=12,上顶,上顶),COLOR00FFFF; DRAWNUMBER(CURRBARSCOUNT=12,阻力,阻力),COLOR00FFFF; DRAWNUMBER(CURRBARSCOUNT=12,支撑,支撑),COLOR00FFFF; DRAWNUMBER(CURRBARSCOUNT=12,下底,下底),COLOR00FFFF; DRAWTEXT(CURRBARSCOUNT=20,AAA*0.9995,'最高:'),COLORFFAAFF; DRAWTEXT(CURRBARSCOUNT=20,BBB,'最低:'),COLORFFFF00; DRAWTEXT(CURRBARSCOUNT=20,上顶,'上顶:'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=20,阻力,'阻力:'),COLORFFFF00; DRAWTEXT(CURRBARSCOUNT=20,支撑,'上支撑:'),COLORFFFF00; DRAWTEXT(CURRBARSCOUNT=20,下底,'下底:'),COLOR00FFFF; DRAWTEXT(CURRBARSCOUNT=20,中G,'平衡:'),COLOREEEEEE; {DRAWTEXT(CURRBARSCOUNT=20,强弱界定,'强弱界定:'),COLORMAGENTA; DRAWTEXT(CURRBARSCOUNT=20,支撑2,'下支撑:'),COLOREEEEEE;} VAR1:=EMA(EMA(C,13),13); 控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000; 无庄控盘:=控盘<0; 有庄控盘:=控盘>REF(控盘,1) AND 控盘>0; VAR2:=100*WINNER(C*0.95); 主力出货:=控盘<REF(控盘,1) AND 控盘>0; 高度控盘:=VAR2>50 AND COST(85)<C AND 控盘>0; A10:=CROSS(控盘,0); 控盘B:=FILTER(IF(A10,1,0),5); STJ01:=控盘<REF(控盘,1) AND 控盘>0.5; STJ02:=控盘>0; BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2; BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ; DRAWTEXT(CROSS(JJA,支撑2) AND 控盘<-0.2,强弱界定*0.995,'★有庄'),COLORMAGENTA,LINETHICK5; A25:=HHVBARS(CLOSE,60); 突破1:=FILTER(((CROSS(CLOSE,((REF(REF(CLOSE,A25),1))*1.001)))AND(REF((A25>= 5),1))),10),POINTDOT,LINETHICK0; STICKLINE(突破1,AAA,BBB,1,0),COLORF600A9; DRAWTEXT( 突破1,中G-0.02,'★突破'),COLORF600A9; DRAWTEXT((((SUM((突破1>0),0))=1)AND 突破1),(CLOSE*0.99),'最佳买点'),COLORWHITE; DRAWTEXT((((SUM((突破1>0),0))=2)AND 突破1),(CLOSE*0.99),'次佳买点'),COLORWHITE; DRAWTEXT((((SUM((突破1>0),0))=3)AND 突破1),(CLOSE*0.99),'理想买点'),COLORWHITE; DRAWTEXT((((SUM((突破1>0),0))=4)AND 突破1),(CLOSE*0.99),'及格买点'),COLORWHITE; DRAWTEXT((((SUM((突破1> 0),0))>=5) AND 突破1),(CLOSE * 0.99),'突破'),COLORWHITE; JJ:=SUM(C*V,0)/SUM(V,0),COLOR00FFFF; LC:= REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; GB:IF(RSI1>80,H*1.0005,DRAWNULL),CIRCLEDOT,LINETHICK5,COLORFFFF00; GBB:IF(RSI1>84,H*1.0008,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF; 均:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;{大智慧分时主图用}a:="LTFunc4@FORLT2"; s1:="LTFunc4@LT_S1"; hs:="LTFunc4@LT_HS"; ls:="LTFunc4@LT_LS"; p1:="LTFunc4@LT_P1"; upp:="LTFunc4@LT_UPP"; udd:="LTFunc4@LT_UDD"; {hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd}; d1:=ema(abs("ddx.ddx"),60); d2:=min("ddx.ddx"/d1,10); 能量级别:d2,linethick0; N:=4; 时长:=if(HOUR>=10 AND HOUR<15 ,1,0);{10点至 15点} 均线:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(vol*100,0))); 均线H:(均线*1.007 ),COLORFF6600,LINETHICK0,LAYER0; 均线L:(均线/1.005 ),COLOR00FF00,LINETHICK0; 均线横盘:=C<均线H and C>均线L; 量比:=sum(vol,0)*240/dynainfo(38)/barscount(c); 量比5分钟:=sum(量比,5); 量比10:=sum(量比,10); 上个5分钟量比:=量比10-量比5分钟; 放量:=sum(VOL,6)>REF(ma(VOL,30),1)*10; CC:CLOSE,COLORWHITE,LINETHICK2; partline(CC,CC>=ref(CC,1),rgb(255,151,255),CC<ref(CC,1),rgb(0,255,255)),linethick2,LAYER0; 横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1; 横涨:=横盘 AND 放量 AND (C>均线H); 横跌:=横盘 AND 放量 AND CROSS(均线L,C) ; 突破:=FILTER(横涨,100); 下破:=FILTER(横跌,50); DRAWTEXT(突破,均线H,'★突破'),COLORFF00FF; MA30:=EMA(CLOSE,30); 强弱界定:EMA(CLOSE,900); STICKLINE((MA30>强弱界定),MA30,强弱界定,1,0),COLOR0000FF; STICKLINE((MA30<强弱界定),MA30,强弱界定,1,0),COLOR00FF00; DRAWICON(CROSS(MA30,强弱界定),H,7); H1:=MAX(DYNAINFO(3),DYNAINFO(5)); L1:=MIN(DYNAINFO(3),DYNAINFO(6)); P1:=H1-L1; 阻力:L1+P1*7/8,dotline,COLOR00DD00; 支撑:L1+P1*0.5/8,dotline,COLOR00DD00; VERTLINE(突破,3),COLORFF00FF,LINETHICK2; JX:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW; {叠加大盘线} TC:=STRCMP(STRLEFT(MARKETLABEL,2),'SZ'); DPSH:="SH000001$CLOSE"/HHV(STKINDI('SH000001','分超引用.昨收#DAY'),0); DPSZ:="SZ399001$CLOSE"/HHV(STKINDI('SZ399001','分超引用.昨收#DAY'),0); DPC:=IF(INBLOCK('A股板块'),DYNAINFO(3)*IF(TC=0,DPSZ,DPSH),C); POLYLINE(C>0,DPC),COLOR3399ff,LINETHICK1,LAYER0; 流通盘大小:=FINANCE2(37)/1000000*100; DRAWTEXTABS(280,220,'流通盘大小:'+NUMTOSTRN(流通盘大小,2)+'亿'),LINETHICK1,ColorYELLOW; A1:=DYNAINFO(23) / DYNAINFO(22); A2:=DYNAINFO(17); DRAWTEXTREL(400,700,IFS((A1 >= 1),'能量:'+NUMTOSTRN(A1,2)+' 量比: '+NUMTOSTRN(A2,2),'')),linethick4,colorWhite; DRAWTEXTREL(400,700,IFS((A1 < 1),'能量:'+NUMTOSTRN(A1,2)+' 量比: '+NUMTOSTRN(A2,2),'')),linethick4,colorWhite; VAR1:=EMA(EMA(C,13),13); 控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000; 无庄控盘:=控盘<0; 有庄控盘:=控盘>REF(控盘,1) AND 控盘>0; VAR2:=100*WINNER(C*0.95); 主力出货:=控盘<REF(控盘,1) AND 控盘>0; 高度控盘:=VAR2>50 AND COST(85)<C AND 控盘>0; A10:=CROSS(控盘,0); 控盘B:=FILTER(IF(A10,1,0),5); JJ:=DYNAINFO(11); P:=55;S:=8;M1:=3; 能量:=(EMA(C,S)-EMA(C,P))*10; 空头:=EMA(能量,M1); BTJ1:=(C-JJ)/JJ<-0.005; BTJ11:=(C-JJ)/JJ<-0.03; BTJ12:=ref(LAST(JJ>=REF(JJ,1)),1)>=4 AND (C-JJ)/JJ<0.005; STJ1:=(C-JJ)/JJ>0.005; STJ01:=控盘<REF(控盘,1) AND 控盘>0.5; STJ02:=控盘>0; BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2; BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ; DRAWTEXT(CROSS(CC,支撑) AND 控盘<-0.2,强弱界定*0.985,'★有庄'),COLORMAGENTA,LINETHICK5; a25:=HHVBARS(CLOSE,60); 突破1:FILTER(((CROSS(CLOSE,((REF(REF(CLOSE,a25),1))*1.001)))AND(REF((a25>= 5),1))),10),POINTDOT,linethick0; STICKLINE(突破1,(CLOSE*0.99),CLOSE,5,0),ColorF600A9; DRAWTEXT((((SUM((突破1>0),0))=1)AND 突破1),(CLOSE*0.99),'最佳买点'),colorWhite; DRAWTEXT((((SUM((突破1>0),0))=2)AND 突破1),(CLOSE*0.99),'次佳买点'),colorWhite; DRAWTEXT((((SUM((突破1>0),0))=3)AND 突破1),(CLOSE*0.99),'理想买点'),colorWhite; DRAWTEXT((((SUM((突破1>0),0))=4)AND 突破1),(CLOSE*0.99),'及格买点'),colorWhite; DRAWTEXT((((SUM((突破1> 0),0))>=5) AND 突破1),(CLOSE * 0.99),'突破'),colorWhite;

如未说明则本站原创,转载请注明出处:NULL » 今日指标:史上最牛黄金分割分时主图通达信+大智慧版源码奉献